Nursing Productivity Pak

Sample Screenshots
The Nursing Productivity Pak currently contains 4 Nursing Tools comprised of 11 relational databases, 92 layouts, 347 fields, 300 scripts and calculations...and continues to grow in functionality.  The four tools are the Staff Assignment Tool, the Staffing Calculator, the Acuity Grading Tool and the Medication Information Tool.  Great efforts have been made to ensure that each tool is easy to understand and easy to use, especially for new computer users.  Most layouts will have a Help button that will lead you to additional information for that area.  Expanded assistance has been included in this Tutorial to cover subjects not addressed elsewhere.

The Staff Assignment Tool is a simple but powerful solution that reduces wasteful paperwork while improving nursing communication and ensuring quality patient care.  Each Nurse and CNA receive patient data on work forms that are legible, current and complete, at the beginning of each shift!  This is especially important for safe and error free delivery of care by registry, floating and newly hired employees.  With a minimum of overhead, Intershift communication is expedited and continuity of care is improved.  Staff members no longer need to hurriedly search out patient information and fill out blank worksheets at the beginning of each shift.  Staff members are no longer forced to decipher unintelligible report forms.  Report times are shortened and crucial, current information is passed on.

· HOW DOES IT WORK? 

Typically, each unit customizes it's own software with unique terminology for diagnosis/treatments, etc., room #'s, Dr.'s, staff.  This feature is one of NPP's great strengths.  Each unit/floor will designate a shift to update the patient care data QD.  This is really the only "cost" to using the program but the dividends are clear and accurate patient care info as displayed on Charge Nurse's report sheet and customized nursing/cna worksheets.  After the initial entering of unit and patient care data, the QD update is usually quick and easy, depending largely on the patient turnover of each unit.

At the end of each shift, someone clicks a couple of buttons to print out the worksheets to give to the oncoming nursing staff.  Report time is shorter, to the point and more efficient as nurses are freed from the wasteful daily copying of all information from the RAND.  They are more likely to note small details, emerging issues and ask questions of off-going nurses when freed of the drudgery of filling out blank worksheets.  Of course, nurses still check and update each worksheet against the RAND as part of taking report.  CN's love the voluminous information that is displayed on their 8 1/2 X 14 inch (landscape format) worksheets and how easy staff assignments are done.  Nurses that float to your unit will positively love it, making the transition easier for the nurse and safer for the patient.  You will no doubt soon hear that nurses are asking for the software back at their home units.

The network version of the software will run on any machine that is currently being used as a server.  Each client pc will need to have a copy of Filemaker Pro installed on it, while the data is stored centrally on the server.  A client-server setup necessarily requires more tech involvement.

  Implementing a pilot program on just one or two units would be an inexpensive way to evaluate whether this approach is for you.  

The runtime version of the software requires minimal pc resources and will run on any pc whose processor runs at 300 mhz or greater.  RAM can be as low as 128 mb. 

The Acuity Grading Tool is used to grade each patient by up to 16 patient care categories (2 categories are optional).  The score is automatically tabulated and a user-configurable formula is applied to arrive at each patient's acuity level.  This Acuity Rating appears on each nurse's and aide's Patient Care Worksheet, the Patient Data Form and the Patient Census List.  This data is automatically shared with the Staffing Calculator (see next item).  This formidable and complex task of Acuity Grading is made simple and quick with the use of this tool.

· You can experiment with the Acuity Grading Tool immediately with the included sample patient data. - From the Main Menu, click on the Grade Patient Acuity (Patient Classification Form). - Place your initials in the popup window that appears, pressing the Continue button. - There now appears a sample patient with various Patient Care Categories already filled out. - The Acuity Level appears at the bottom and will also appear on the Patient Data Form, the Patient Census List, the Daily Staffing Guide and each shift's Staff Assignment.

· The Daily Staffing Guide is a user-configurable worksheet that is used by Charge Nurses to incorporate current Patient Acuity levels with each shifts staffing requirements. Each unit can receive a unique "Shift Weight", depending on how the work load is divided between the various shifts.

· From the Daily Staffing Guide, you can click on the Staffing Calculator button. This tool can be used as "scratch paper" to calculate staffing needs depending on various staffing/acuity scenarios. 

The Staffing Calculator computes (again via user-modifiable parameters) the number of RN's, LVN's and CNA's that are allowed for an individual shift, patient census and patient acuity.  Each shift can be weighted according to their comparative workload. 

The Medication Information Tool is a Patient and Family Education resource that provides much needed information regarding each patient's medications, i.e. medication names, times, purpose, dosage, routes, interactions and side effects.  It enables nursing to quickly and easily generate custom Medication Guides for patients and their caregivers.  The database stores all pertinent patient information and the medications that are presently ordered.  With the click of a mouse, medications are chosen from a popup menu of over 300 commonly prescribed medications.  The medication's purpose, possible side effects and interactions are automatically filled in when the medication name is chosen.  As part of the Nursing Productivity Pak, this important Patient and Family Education component is no longer a difficult "chore", but can be automatically generated as part of the normal discharge process.

Basic Operation:

1.  After adding the Staff and Patient names and Room #'s, return to the Main Menu and click on "Create Staff Assignment", then selecting the appropriate Shift (DAY, PM or NOC).

2.  Next, you are taken to Today's Staff, a form where you choose from the available Nurses in the popup Menus and assign the number of patients that each nurse will be caring for. When finished, click on the "Assign By Team"  or "Assign In Order" button.

3.  A tentative Assignment is generated.  You can then make final adjustments as needed.

4.  Click on the "Print All Staff Assignments" button.  Each Nurse's and CNA's Worksheets will be printed in the order that they appear on the Today's Staff page. 

5.  You are prompted to Save each Assignment, using the same format each time.  Please use the following format:  monthDAYyearSHIFT  (for example: "091598noc"  for September 15, 1998, night shift).  In this way, you will be able to return to any Day and Shift and view past Assignment Data. Also, be sure to save the Assignment in the Past Assignments Folder, so you can easily find it later.

6.  "Print Individual Assignments" allows you to go back and change one person's assignment without having to print all assignments again.

7.  The Calendar button displays a simple reference calendar.  Clicking on an individual day will display an hourly schedule for that day. 

Performance Tips:

-  The upper left margin contains a "rolodex" graphic that enables navigation through records.  The button above that allows navigating between various Database Forms.  In the lower left corner, there are two "mountain" icons that allow zooming in and out for easier viewing.  Immediately to the right of the "mountain icons" is an icon that switches the left margin of the screen on and off. To the right of these small icons is a longer bar that is a popup window that allows you to choose between "Browse", "Find" and "Preview". (Warning: If someone accidently changes this button to "Preview", the screen will be visible but the buttons won't work! So leave it on "Browse".) The NPP Shortcut Menu, at the top of the window, contains various convenient and useful commands.  Finally, the "Window" Menu allows navigating between various open database files.

-  When creating a Staff Assignment, it's always a good idea to first go to the Patient Census List and confirm that Patient Room #'s and Names are current.  If you get a late admit close to shift change, it is only necessary to add the patient's name and room number in order to include them in the assignment.  -  Encourage all staff members to update Patient Data, but assign a Unit Secretary or other staff to update Patient Data at least daily and more often as needed. CNA's can click on the "CNA Data Entry" button on the Main Menu to update BM's and Shower dates. This usually takes just a few minutes. -  If you have some type of problem part way through the printing of the assignment (e.g. running

out of ink in your printer, etc.), take note of which worksheets were not printed.  It's not necessary to redo the assignment.  Simply use the Layout Navigation button (located above the miniature "Rolodex" in the left margin) to navigate to the "Print Individual Assignments" layout (if the left margin is not visible, click on the icon to the right of the Zoom Icon at the bottom).  You can then click on the individual nurses that still need their  Worksheets printed without starting from the very beginning.

-  Another situation you may encounter is when a nurse is assigned to work only four hours, with

the remaining nurses dividing up her/his patients for the last half of the shift.  One way to handle this is to initially make out the assignment as it will be after the 4 hour nurse leaves.  Then do a second assignment that includes the 4 hour nurse.  Instead of printing all the assignments again, navigate to the "Print Individual Assignments" layout and print only the 4 hour nurse's worksheet.

-  To make NPP easy to start for everyone, create a Shortcut to the Nursing Productivity Pak Application  file and leave it on the Desktop and other convenient places.

-  Notice that this database is actually 11 databases that are dynamically linked to one another. You can manually navigate between them by using the "Window" menu.

Importing Past Patients:  If you would like to import a previous patient's data into the current Patient database (Patients.fp3), follow these steps:

1. Go to the File Menu, choose Open and open "PastPatients.fp3". This is a separate database where a patient's data is stored when deleted from the current Patient database.

2. Do a "Find" for one or more patients and then "Save" the results of this search, giving the record/s a unique name and saving it somewhere you can find it easily (like the Desktop).

3. In the "Window" menu, navigate back to "Patients" and choose "Import" from the "File" menu.

4. Choose to Import the record/s that you found in "PastPatients". This will add the record/s to the current list of patients.

How to Backup:  The simplest way to backup your data is to take the entire Nursing Productivity Pak Folder and duplicate it. You can then compress it and store it on separate media, preferrably in a different location. This method takes up the most storage space. Another method is to only duplicate and compress your main data files, i.e. staff.fp3, patients.fp3, pastpatients.fp3 and medinfo.fp3. Here's how:  1. Create a folder called NPP Backup. 2. Inside NPPBackup create another folder called "62999MiniBackup" (starting with the current date). 3. Place only your main data files in this folder, compress it and then discard the original. You now have a compressed file with your most crucial data archived. If the worst did happen (e.g. fire, power outage and corrupted data), you could then easily reinstall your original copy of NPP and perform the Upgrade task by going to Main Menu/ Register/ Upgrade.

Protect your data:  The number one cause of corrupted data in any type of database is the occurance of a power outage while the database is open.  For this reason, it is wise to purchase a UPS device (Uninterruptable Power Supply). This provides continuous power in the event of a power loss, usually for several hours. It will at least give you time to quit the application and turn off the computer until normal power is resumed.  If your data does somehow become corrupted, an error message will be displayed, stating that a particular file is corrupted and will need to be Recovered.  Go to the File Menu and choose "Recover...".  The file will be fixed and given a name with the word "recovered" tacked on.  You will then need to replace the old, corrupted file with the new recovered file, renaming the recovered file with the old name. When you restart NPP it will then use the newly repaired file.  DO NOT change the names or locations of the files from where the program expects to find them.

